000097 : License Key cannot be found
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Created: |
26 Feb 2008 |
Last Updated: |
26 Feb 2008 |
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Message
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There is a known issue for users of ConnectIt-Sage50 v1.5 and v1.6 and ConnectIt-MSCRM v1.0 following an upgrade to QuoteWerks 4.0 build 33. Users may be prompted that a License Key cannot be found.
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Cause |
The problem may affect any users where the QuoteWerks software has been installed more than once on their computer. This is due to a change in the QuoteWerks API for build 33 and the way that the “Installations” collection is handled:
"For API users, QuoteWerksBackend.Installations collection now includes all the installations that are available through the local machine. The collection lists the installations in the priority assigned through the QuoteWerks Launcher app. The collection only lists installations that are currently accessible which is useful in situations where QuoteWerks is installed on the network and on the local laptop. Typically in that environment, the QuoteWerks Launcher would be used to set the Network installation as the first installation to try and use and if it is not available, then use the laptop installation. When the laptop is disconnected from the network, the Laptop installation will be the first installation listed in the collection."
To verify whether the “License Key cannot be found…” prompt is due to this change, please open the ConnectIt Registration screen. The Registration Seed value may be blank or have a value which refers to an old installation:
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Resolution |
The ConnectIt development team are working on a more permanent fix and this will be published as soon as possible. In the meantime, as a temporary fix the registry can be edited to manage the QuoteWerks Installation collection and ensure that ConnectIt License Manager retrieves the correct installation details.
Step 1: In HKEY_CURRECT_USER\Software\QuoteWerks\Version 4\Installations there is a key named “PriorityList” which lists out the installations of QW (in the example illustrated below there are 8 installations a, b, c, d, e, f, g and h).
Step 2: Within the HKEY_CURRECT_USER\Software\QuoteWerks\Version 4\Installations sub folders, identify the folder which contains the Path to the installation of QuoteWerks that you are currently using (in the example illustrated below we are using “S:\QuoteWerks”, so this is installation “h”).
Step 3: Amend the HKEY_CURRECT_USER\Software\QuoteWerks\Version 4\Installations “PriorityList” key to reflect just this Installation (i.e. in the example illustrated below just “h” and not “abcdefgh” as it was listed previously).
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