000360 : Login timeout expired opening ConnectIt Registration or testing database connection
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Created: |
23 Feb 2016 |
Last Updated: |
23 Feb 2016 |
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Message
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When opening ConnectIt Registration or testing the QuoteWerks database connection, you receive a ‘login timeout expired’ error. When opening Registration, this will also be followed by messages about QuoteWerks looping through the backend DLLs.
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Cause |
This may be because the QuoteWerks backend QW.DLL or QW4.DLL is not registered correctly.
Note that in debugging the issue, you may note that if you the Registration application, you will receive an error about ‘timeout expired’ and looping through the backend qw.dll’s. If you open the Configuration application and test the database connection, then it will fail with a timeout expired on the first attempt but pass on any subsequent tests until you close and reopen the application when again it will fail on the first attempt and pass on the second.
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Resolution |
In the QuoteWerks Medic Utility | Utilities menu | API Info option, make sure that the QW.DLL or QW4.DLL path is as expected, i.e. the same as the path where QuoteWerks is installed on your server or workstation. If it is not, then use the Windows regsvr32 application to register it manually. Once you have run regsvr32, then recheck the details in the QuoteWerks Medic Utility | Utilities menu | API Info option to make sure that the changes have been successful.
To run the regsvr32 application, open either a Run or Command prompt and enter “regsvr32” followed by the path of the full path and filename of the QW.DLL or QW4.DLL.
For example:
* regsvr32 C:\Applications\QuoteWerks\qw.dll
* regsvr32 Q:\QuoteWerks\qw.dll
* regsvr32 \\MyServer\MyShare\QuoteWerks\qw.dll
* regsvr32 \\192.168.0.1\MyShare\QuoteWerks\qw.dll
Note that if there are any spaces in the folder names, then the path and filename should be in brackets:
* regsvr32 “C:\My Applications\QuoteWerks\qw.dll”
* regsvr32 “Q:\My QuoteWerks\qw.dll”
* regsvr32 “\\MyServer\My Share\QuoteWerks\qw.dll”
* regsvr32 “\\192.168.0.1\My Share\QuoteWerks\qw.dll”
You should be prompted that the registration was successful. If the registration fails, then please ensure that the path is correct and that you are running the Run or Command prompt ‘As Administrator’.
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